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PREFACE 
 

In addition to the APEC Energy Statistics 2012 publication, the Coordinating Agency for the Expert Group on 

Energy Data Analysis (EGEDA) released a CD-ROM version of the APEC Energy Analytical Tool 2012. This tool 

has the following advantages: 

Historical Data from 1980-2010 

A retrieve Function 

An analysis Function 

The tool supports retrieval and analysis of data and provides various viewing options that have been prepared in 

consultation with member economies in the APEC region. 

Aside from energy data, the tool includes socio-economic data, such as population and GDP, through a license 

from the World Bank. 

The tool is developed to work on the Windows 2000, XP or Later. There can be problems due to different versions 

of common DLL programs which are stored during the installation of application software. 

 

Questions should be addressed to: 

The Energy Data and Modelling Center 

The Institute of Energy Economics, Japan 

Inui Bldg., Kachidoki 13-1, Kachidoki 1-Chome, Chuo-ku, 

Tokyo 104-0054, Japan 

Telephone: (81)-3-5547-0215 

Facsimile: (81)-3-5547-0226 

E-mail: wwwadmin@edmc.ieej.or.jp 

Website: http://www.ieej.or.jp/egeda/ 

 

To purchase the tool, please contact: 

The APEC Secretariat 

35 Heng Mui Keng Terrace,  

Singapore 119616 

Telephone: (65)-6891-9600 

Facsimile: (65)-6891-9690 

E-mail: info@apec.org 

Website: http://www.apec.org 
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1. Installation 

 

1.1 Before installation 

Before installing this system on your computer, please take note of the following: 

a. Close any applications with a working Internet connection; 

b. Undertake the backup procedure for applications that use the old version of OLECTRA CHART 

2D OCX and SPREAD OCX, and close those applications. 

 

1.2 Installing the tool 

 

(1) Place the “APEC Energy Statistics Analysis Tool 2012” in your CD-ROM drive. The dialog box will open 

automatically. If not, open the folder in the CD-ROM, select the “Setup.exe” file and then click the [OK] 

button. 

 

 
 

(2) Click the [Next] button and you will brought to the license agreement box. Click on [Yes] to continue 

installation. The “Readme Information” will appear. Click on [Next] to continue. Please enter your user 

information and click on [Next]. A dialog box that allows the designation of the installation folder will appear. 

 

 

 



 
Installation 

APEC ENERGY STATISTICAL ANALYSIS TOOL 2012 USER MANUAL 2 

(3) Using the [Browse] button, designate the installation folder. After having assigned the installation folder, the 

program folder will be shown as below. 

 

 

 

(4) After clicking the [Next] button, a confirmation screen will be displayed.  Click the [Next] button to start 

copying files. 

 

 

 

(5) While the files are being copied, installation progress will be displayed. 
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(6) Before click on [Finish], you have two options: One is to restart your computer right away or restart your 

computer later. You have to restart your computer before you can use the Tool. Clicking on [Finish] will 

complete installation. 

 

 
 

(7) If you select [I will restart my computer later], you can not use the Tool right away. You can begin using it after 

you have rebooted your computer. 
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2 Configuration 

 

2.1 Hardware 

The personal computer hardware requirements of this system are as follows: 

* Computer: IBM PC/AT compatible computer 

* CPU: Pentium or later CPU (Pentium-II 200MHz or faster recommended) 

* Memory: At least 32 megabytes of RAM (64 MB recommended) 

* Hard disk: At least 20MB of disk space (50MB or more recommended) 

* Video: At least 640 x 480 display resolution, 16 colours and 15 inch monitor (1024 x 768, 256 

colours and 17 inch recommended) 

* Miscellaneous: printer, mouse, keyboard, modem and CD-ROM drive 

 

2.2 Software 

* OS: Microsoft Windows 2000, XP or later 

* Other: Dial-up networking TCP/IP protocol (when working with modem) 
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3 Database 

 

3.1 Member Economies 

The database covers the 21 APEC member economies: 

Australia, Brunei Darussalam, Canada, Chile, China, Hong Kong China, Indonesia, Japan, Korea, 

Malaysia, Mexico, New Zealand, Papua New Guinea, Philippines, Peru, Russia, Singapore, Chinese 

Taipei, Thailand, United States of America and Viet Nam 

 

3.2 Timeframe 

The database encompasses the years 1980 to 2010 for both energy and socio-economic data, except for the 

following economies: 

Russia:         1990-2010 for energy data 

Viet Nam: 1990-2010 for energy data 

 

3.3 Energy Data 

The database contains several kinds of energy data as follows: 

Energy Balance Tables in thermal units (TOE, Joule) 

Energy Balance Tables in common physical units 

 Solid:  TONNE 

 Liquid:  1,000 KL 

 Gas:  1,000,000 SCM 

 Electricity: GWh 

Power Generation Table 

Power Capacity Table 

Fuel Consumption Table for Power Generation 

 

3.4 Socio-economic Data 

The following data are included: 

Population 

Gross Domestic Product (nominal local currency unit or LCU) 

 Private consumption 

 Government consumption 

 Fixed capital formation 

 Stock change 

 Exports 

 Imports 

Gross Domestic Product (Constant price = 2000, LCU) 

 Private consumption 

 Government consumption 

 Fixed capital formation 
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 Stock change 

 Exports 

 Imports 

Sectional shares of real GDP 

 Agriculture, fishery and forestry 

 Industry 

 Manufacturing 

 Services etc 

Foreign exchange rate (LCU/US$) 

Purchasing Power Parity (International $ /LCU) 

The following items have been estimated based on the above data: 

Real GDP (2000 price, 2000 US$) 

Real GDP (2000 price, 2000 PPP) 

Nominal GDP (Current US$) 

Real GDP per Capita (2000 price, 2000 US$) 

Real GDP per Capita (2000 price, 2000 US$) 

Nominal GDP per Capita (Current US$) 

 

3.5 Source 

Energy data: Submissions from national administrations, except for Papua New Guinea, which comes 

from the UN Energy Database for 1980-2003, and is estimated based on national data for 

1994-2003 

Socio-economic data: World Development Indicators by World Bank 
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4 System operation 

 

4.1  Common operations 

The system provides standard Windows functions for each menu item. These include abstract searches, custom 

searches, graphing results and printing. 

 

4.1.1 Printing 

After selecting [File] > [Print] a print set-up dialog box will be displayed. 

 

 

 

After selecting and confirming a printer is online, click the [OK] button.  The printer configuration can be changed 

by clicking on the [Properties] button or choosing [File] > [Print Setup]. 
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4.1.2 Print preview 

The print preview function shows how the printed page will look, and is available by selecting [File] > [Print 

Preview]. 

 

 

To change the scale, use the [Zoom-In] and [Zoom-Out] buttons.  Select [File] > [Print Setup] to change the paper 

size.  The change will be reflected in the preview window. 

 

 

 

4.1.3 Saving the results 

Data can be saved in Microsoft Excel 95/97 format. Graphs displayed on the screen can be saved as bitmaps. 
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4.1.4 Transferring data to the clipboard. 

Data tables, graphs, and sheets can be saved to the clipboard, which allows information to be transferred to other 

applications. 

The diagrams below show the transfer of a graph into “Microsoft Paint”. 
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4.1.5 About Help 

The system provides a help system through the F1 function key, which includes instructions on operations, and 

explanations of terminology and error messages. There is also a user manual in Word format. 

 

 
 

To see version information, select [Help]>[About]. 

 

 
 

4.1.6 Editing spreadsheets 

(1) Making a copy 

a. Designate a block to be copied and select [Edit]>[Copy]. 

c. The data in the block will be transferred to the clipboard. 
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(2) Pasting 

a. Find or create an empty block of cells of the same dimensions as the copied block, and select 

[Edit]>[Paste]. 

 

 

 

(3) Cutting and Deleting 

a. Designate a block and select [Edit] > [Cut].  This operation will cut the data and place it on the 

clipboard. 

b. Designate a block and select [Edit] > [Delete] > ([Row] or [Column]).  This operation will delete the 

data entirely. 

 

 

 



 
System operation 

APEC ENERGY STATISTICAL ANALYSIS TOOL 2012 USER MANUAL 12 

(4) Undo 

The undo command recovers data that has been deleted by the previous paste, cut, or delete operation.  Only the 

most recent operation can be undone with this command. 

 

 

 

4.2 Displaying an energy-balance-table 

Select [Database] > [Energy-balance] > [Typical] to generate an energy balance table.  This window can also be 

accessed by selecting [Options] from the [View] menu. 

 

 

 

Options that are available in this window: 

Member: Select member economy. 

Data Set: Select level of detail required. 

Year: Designate the year. 

Unit: Select units. 

[OK] button: Confirm operation.  Display the energy balance table. 

An energy-balance-table by member and by year will be displayed as follows. 
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Operations that can be undertaken in this window: 

A table image can be copied as a bitmap to the clipboard. 

A table can be printed. 

The data can be saved to a disk. 

The Windows screen can be split for more convenient analysis. 

 

Splitting the window. 

Select [Window] > [Split]. 

Choose an appropriate partition line to divide the window into two. 

The window can also be split horizontally to produce a four pane window. 

 

 

 

Removing the split 

Set the mouse cursor on the split line. 

Drag the line to the far left. 
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4.3 Carrying out a search. 

After selecting [Database] > [Energy-balance-table] > [Custom], a dialog box with search options will be 

displayed. 

 

 

Select item: An item is selected when highlighted. 

Cancel selection: An active item can be inactivated with the left mouse button clicked as the item is 

highlighted. 

Multiple choices are also available. 

Select All button: With this function, all the items on the list will be selected. 

Unselect All button: All the highlighted items on the list will be cancelled (inactivated) with this command. 

A search on selected items (year, energy, sector and unit) is shown below. 
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Operations 

Changing the [Row /Column] and [Year/Member] positions alternately. 

Editing the data (copy, paste, cut, delete, undo, select all) 

Printing the list. 

Saving the data list. 

Transferring data to the clipboard. 

Re-displaying the window when the zoom rate and search conditions have been set. 

Drawing of a graph based on a selected cellblock. 

 

Changing row and column designations 

It is possible to change the designation for both rows and columns using the [Row/Column] feature shown 

below. 
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When the contents of the Row/Column setting are updated, the items on the list will be set to the Fixed items 

[Member economy and Sector]. 

 

To change search conditions, select [Options] from the [View] menu.  The list of conditions will be updated when 

the revision is complete and the [OK] button is pressed. 
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After selecting a block of data from the table, select [Show Chart] from the [Graph] menu, the corresponding graph 

will be shown. 

 

 
 

4.4 Displaying electricity generation 

After selecting [Electricity Power Generation] from the [Database] menu, the dialog box below will be displayed. 

 

 

Possible operations: 

Member: Designate economy 

Year: Designate year. 

Sector: Choose sector. 

Select All: All data is selected. 
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A table of electricity consumption by economy or year will be displayed. 

 

 

On this screen, the display can be changed: 

Row/Column: Change row and column designations. 

Sector: Select the sector to be displayed. 

 

4.5 Displaying electricity generation capacity 

After selecting [Electricity Generating Capacity] from the [Database] menu, an options dialog box is displayed. 

 

 

 

Possible operations: 

Member: Designate member economy 

Year: Designate year. 

Sector: Choose sector. 

Select All: All the data will be selected. 
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A table of the electricity generation capacity by economy by year will be displayed. 

 

 

 

On this screen, the display can be changed: 

Row/Column: Change row and column designations. 

Sector: Select the sector to be displayed. 

 

4.6 Searching the major economic indicators 

Select [Major Economic Indicator Table] from the [Database] menu and a search screen will be displayed. 

 

Select the year and sectors 
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A list of results will be displayed. 

 

Operations 

Changing the [Row /Column] and [Year/Member] positions alternately. 

Editing the data (copy, paste, cut, delete, undo, select all) 

Printing the list. 

Saving the data list. 

Transferring data to the clipboard. 

Re-displaying the window when the zoom rate and search conditions have been set. 

Drawing of a graph based on a selected cellblock. 

 

The contents of the list will be updated when [Row/Column] and the [Fixed Item] are changed.  The next screen 

shows the list in the case where the Year/Sector is selected for the Row/Column setting. 

 

 

 

When the contents of a selection of Row/Column settings are updated, the first items on the list will be set to the 

Fixed items. 
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To change the search conditions, select [Options] from the [View] menu.  The list of the conditions will be updated 

when the revision is done and the [OK] button is clicked. 

 

 

After selecting a block of data from the table, choose [Show Chart] from the [Graph] menu, and the corresponding 

graph will be shown. 

 

 

The result is shown with a graph. 
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When [Show Chart] from the [Graph] menu is selected with a block of the cell-data already specified in a custom 

search, a graph window for the data block will be displayed as shown below. 

 

Operation 

Printing a graph image. 

Saving an image to a file. 

Transferring a graph to the clipboard 

Re-sizing graph 

Changing the chart type 

Changing the graph properties 

Selecting [Graph] > [View 2D Chart] > [Graph name] will change the graph display. 

 

The following six graphs are examples of 2D charts. 

Bar graph and pie graph 

   

Block graph and area chart 

   

Radar charts 
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Selecting [Graph] > [View 3D Chart] > [Graph name] will allow the graph type to be changed.  The following 

three graphs are examples of 3D graphs. 

 

3D bar graph 

   

Select [Properties] by clicking the right mouse button and a window will appear that allows graph property settings 

to be changed. 

 

The following four menu items [HiLo, Open Close, Candle, Polar] in the Chart type menu, should not be selected 

because of system management limitations. 

 

4.7 Displaying variables 

After selecting [Variable Explorer] from the [Analysis] menu, the next screen will be displayed.  The 

energy-balance-table data, data of the table of electricity, CO2 emission data, and the data of major economic 

indicators will be all listed on the screen. 
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Operations 

Viewing the contents of the database. 

Sorting highlighted items. 

Transferring selected items to the clipboard. 

Displaying extra details for selected items. 

Generating new variables. 

 

There are four ways to display items - large icons, small icons, bare lists, or in full lists.  These are available 

through the [View] menu. 

 

A bare list 

 

 

Small icons 
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Large icons 

 

Clicking the column button rearranges the list.  The next screen shows an example of an ascending order sort of 

the name column. 

 

There are two methods in selecting an item.  Clicking the left mouse button while the pointer is over an item 

selects that item.  Clicking on individual items while the shift key is pressed will select a number of items.  For 

this purpose, the [Ctrl] key works in the same way as the [Shift] key. 
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Detailed information will be displayed when an item on the list is specified (Pressing the return key will bring the 

same result). 

 

 

This screen consists of three parts, the data list by year, time series figures by years, and a graph of annual growth 

rates against the preceding year. 

 

Operations 

Transferring the three parts to the clipboard. 

(Any part can be individually transferred to the clipboard). 

Saving data to disk. 

(The data in the data list will be saved, while the other parts are saved as bitmaps). 

Changing the chart type 

Changing graph properties. 

Selecting [Graph] > [View 2D Chart] > [Graph name] will allow the graph type to be changed.  The following 

graphs are examples of 3D chart graphs 

 

Bar graph and 3D bar graph 

   

 

Select [Properties] by clicking the right mouse button and a dialog box will appear that allows graph property 
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setting to be altered. 

 

 

Any modification of the data will be immediately reflected in its graph. 

The use of a logarithmic axis is recommended when the maximum value is much larger than the minimum value. 

The following four menu items [HiLo, Open Close, Candle, Polar] in the Chart type menu, should not be selected 

because of system management limitations. 

 

Registering new variables 

To register new variables, select [File] > [New] and a time series data input box will appear.  Data can be 

registered by variable name, economy, comments, and units.  The range of the display can be changed by using the 

year spin button. 

 

 

 

Once the required information is entered, and the member drop-down list procedure complete, the [OK] button will 

register the new data. 
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4.8 Updating the local data file 

(1) After selecting [Update Data] from the [Tool] menu, the following screen will be displayed. 

 

 

From the Internet 

The URL of the Web site required to access the latest data on the Web site. 

 

 
Operations 

Enter the URL: The URL of the Web site does not need to be entered the first time because the URL has already 

been provided during the installation process. 

Back: Go back to the previous page 

Next: Go to the next page. 

After entering the URL, designate a directory and a file name in which downloaded data will be stored. 
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The downloading of the file starts when the URL and a file name are entered. 

 

 

 

Click the [Next] button on finishing the copy process. 

 

 

A screen for the confirmation of the data version will be displayed.  The version information of the currently used 

data and the data on the Web site will be displayed. 

 

 

 

The registration data will be updated. All operations are now complete. 
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4.9 Utilizing the analytical tools 

The following operations are included. 

Calculation of statistical values 

Regression analysis 

The final test 

 

 

 

 

 

 

 

 

4.9.1 Calculation of statistical values 

After selecting [Statistical Values], the next dialog box will be displayed. 

 
 

By clicking the [Find button] in the text box, a screen for selecting the variable name corresponding to each item 

will be displayed. 

 

 

In this screen, from the drop down menu, select the variable name and economy on which the operations will be 

undertaken.  Click the [OK] button to confirm.  The variable names selected here will be shown in the text box 
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on the variable name designation screen.  By clicking the [OK] button; the designated statistical values will be 

displayed. 

 

 
 

Selecting [Graph] > [Show] will display the graphs. 

 

4.9.2 Regression analysis 

After selecting [Regression], the next screen will be shown as follows. 

 

 

 

By clicking the [Find] button on the right of the screen, a screen for the selection of a variable name 

corresponding to each item will be displayed. The way to designate a variable is similar to that in the display of 

statistical data.  After confirming with the [OK] button, the selected variable will be shown in the independent 

or dependent variable text box that is currently active. 
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Select an operator 

 
By clicking the [Operators] button on the right of the display, a dialog box appears with operators that can be used 

in the procedure.  After selecting an operator from the list box, and confirming with the [OK] button, the operator 

will be added to the text box that is currently in focus.  If the [Clear] button is clicked, all the contents of text box 

will be cleared. 

When the estimation year, OLS method, and the presence of the constant term are entered, clicking the [OK] button, 

will execute the regression analysis.  After the calculation, the next screen will be displayed. 

 

Clicking the [File] > [Registration] button will register the regression equations and they can be used in the final 

test/projection. 

 

A graph of the regression analysis result 
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4.9.3 The final test/projection 

The First formulae registered in the system will be displayed.  One of the regression analysis equations to be tested 

should be clicked.  Then designate a year, and click the [OK] button. 

 

 

 

The next screen will be displayed.  Click on the cell and enter appropriate values in it.  Then designate the 

beginning year of the estimation and the presence of the constant term.  Then click the [Calculate] button.  The 

projected values will come up in the cell as they are calculated. 
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Appendix 1: Troubleshooting 

 

Error messages 

 

(1) Failure in opening files 

 Probable cause: 

a. A shortage of disk space 

b. A file has been deleted for some reason during the execution of the application 

c. Files has not been registered in the registry 

Solutions: 

a. Check the disk space. 

b. Restart the program. 

c. Perform the registration to the registry referring to Appendix 2. 

 

(2) Please select a cellblock 

Probable cause: 

Before a cellblock was selected, some other operation had been attempted. 

Solutions: 

Select a cellblock 

 

(3) Please select a numerical cellblock 

Probable cause: 

A cellblock containing only characters is selected. 

Solutions: 

Select a numerical cellblock 

 

(4) Failed to read registry data 

Probable cause: 

a. The registry is damaged. 

b. The keys that have been registered in the registry have changed for some reason. 

c. Items such as the key, the name of the values or the data have not been registered in the registry. 

Solutions: 

a. Recover the registry by executing the Windows’ registry recovery system 

b. Perform the registration to the registry referring to Appendix 2. 

 

(5) The letters “http://” are missing at the top of the URL. 

Probable cause: 

“http://” not entered in the URL 

Solutions: 

The “http://” should be entered 
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(6) Can not execute analysis program 

Probable cause: 

a. A shortage of memory for the environmental variables 

b. A 16 bit program has failed to be executed 

Solutions: 

a. Close other applications 

b. Try to execute on another PC 

 

(7) Failed to find data to be set to the chart 

Probable cause: 

a. A shortage of the disk space 

b. A file has been deleted for some reason during the execution of the application 

Solutions: 

Check disk space 

Restart the program. 

 

Other memory related problems 

(8) Failed to create preview view 

(9) Failed to generate bitmap file 

(10) Cannot load DIB file 

(11) Failed to allocate memory 

(12) Not enough memory to copy selected data into clipboard 

(13) Failed to copy selected data into clipboard 

Probable cause: 

Not enough memory is available. 

Solutions: 

Check system resources 

Close other applications 
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Appendix 2: Registration to the registry 

 

Main key: HKEY_CURRENT_USER 

 

Key1: Software 

Key2: IEEJ 

Key3: APEC Energy Statistical Analysis Tool 

Key4: FileDir 

 Settings 

 

Value name and the data 

Value name Data 

 

FileDir 

analysis tool [INSTALL DIR]\apectool.exe 

ebdata  [INSTALL DIR]\ebdata 

ebdata2  [INSTALL DIR]\ebdata2 

ebadata3  [INSTALL DIR]\ebdata3 

ebtb.idx  [INSTALL DIR]\ebtb.idx 

ebtb2.idx  [INSTALL DIR]\ebtb2.idx 

ecid.idx  [INSTALL DIR]\ecid.idx 

items.dat  [INSTALL DIR]\items.dat 

ken.dat  [INSTALL DIR]\ken.dat 

Readme  [INSTALL DIR]\readme.txt 

 

 

Settings 

APECHomePage http://www.ieej.or.jp/egeda/ 

APECMail mailto:wwwadmin@ieej.or.jp 

EDMCHomePage http://www.ieej.or.jp/edmc/ 

TaskNums 0 

 

 

 




